【活用ガイド】

[English]

JVNDB-2015-000064

Cacti における SQL インジェクションの脆弱性

概要

Cacti はネットワーク機器等から取得したデータをデータベースに蓄積しグラフ化するためのウェブアプリケーションです。Cacti には、graph.php において、ユーザから入力された local_graph_id の値の処理に起因する SQL インジェクションの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社サイバーディフェンス研究所 福森 大喜 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.5 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


The Cacti Group
  • Cacti 0.8.6e およびそれ以前

想定される影響

当該製品にログイン可能なユーザによって、任意の SQL コマンドを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。

開発者によると、本脆弱性は 2005 年にリリースされた Cacti 0.8.6f で修正されているとのことです。
ベンダ情報

The Cacti Group
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-0916
参考情報

  1. JVN : JVN#18957556
  2. National Vulnerability Database (NVD) : CVE-2015-0916
更新履歴

[2015年05月14日]
  掲載
[2015年05月25日]
  ベンダ情報:The Cacti Group (Release Notes - 0.8.6f) を追加
  参考情報:National Vulnerability Database (NVD) (CVE-2015-0916) を追加