【活用ガイド】

[English]

JVNDB-2015-000040

LINE における意図しないアプリ内関数が呼び出される脆弱性

概要

LINE株式会社が提供する LINE は、コミュニケーションアプリです。LINE は、WebView 上の通信の一部で SSL/TLS を使わない HTTP 通信を許可しているため、中間者攻撃により通信内容を改ざんされた場合、意図しないアプリ内関数が呼び出される等の可能性があります。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社スプラウト 末房建太 氏、中澤上明 氏、塩見友規 氏

CVSS による深刻度 (CVSS とは?)

基本値: 5.1 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


LINE株式会社
  • LINE Android 版バージョン 5.0.2 およびそれ以前
  • LINE iOS 版バージョン 5.0.0 およびそれ以前

想定される影響

中間者攻撃 (man-in-the-middle attack) によって通信内容を改ざんされ、不正な JavaScript コードが実行される可能性があります。結果として、意図しないアプリ内関数が呼び出される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。

開発者は次のように述べています:

サーバー側での修正が完了していますが、より安全に利用していただくために、アプリを最新バージョンへ更新するようお願いします。以下の修正が含まれています。
* 暗号化通信の徹底
* 不要なアプリ内関数の削除
ベンダ情報

LINE株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 設計上の問題(CWE-DesignError) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-0897
参考情報

  1. JVN : JVN#41281927
更新履歴

[2015年03月20日]
  掲載