【活用ガイド】

[English]

JVNDB-2014-007612

WordPress 用 Welcart e-Commerce プラグインにおける SQL インジェクションの脆弱性

概要

WordPress 用 Welcart e-Commerce プラグインには、SQL インジェクションの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 6.5 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


コルネ株式会社
  • Welcart 1.4.17 およびそれ以前

想定される影響

第三者により、wp-admin/admin.php の usces_itemedit ページの (1) changeSort または (2) switch パラメータを介して、任意の SQL コマンドを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

WordPress.org コルネ株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-10017
参考情報

  1. JVN : JVN#92828286
  2. National Vulnerability Database (NVD) : CVE-2014-10017
  3. 関連文書 : Welcart e-Commerce usc-e-shop.1.3.12 XSS / SQL Injection
更新履歴

[2015年01月16日]
  掲載
[2015年07月24日]
  JVN#92828286 にあわせ、CVSSによる深刻度、影響を受けるシステム、対策、ベンダ情報、参考情報を更新