【活用ガイド】

JVNDB-2014-005666

libFLAC の stream_decoder.c におけるヒープベースのバッファオーバーフローの脆弱性

概要

libFLAC の stream_decoder.c には、ヒープベースのバッファオーバーフローの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 7.5 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


Xiph.Org
  • Libflac 1.3.1 未満

想定される影響

第三者により、巧妙に細工された .flac ファイルを介して、任意のコードを実行される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Xiph.Org レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-9028
参考情報

  1. National Vulnerability Database (NVD) : CVE-2014-9028
  2. 関連文書 : MGASA-2014-0499
更新履歴

[2014年11月28日]
  掲載
[2015年05月25日]
  ベンダ情報:レッドハット (RHSA-2015:0767) を追加
  参考情報:関連文書 (MGASA-2014-0499) を追加