【活用ガイド】

JVNDB-2014-003474

Apache HTTP Server の mod_status モジュールおけるサービス運用妨害 (DoS) の脆弱性

概要

Apache HTTP Server の mod_status モジュールには、競合状態により、サービス運用妨害 (ヒープベースのバッファオーバーフロー) 状態にされる、重要な資格情報を取得される、または任意のコードを実行される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


Apache Software Foundation
  • Apache HTTP Server 2.4.10 未満
アップル
  • Apple Mac OS X 10.10 から 10.10.2
  • Apple Mac OS X 10.8.5
  • Apple Mac OS X 10.9.5
オラクル
  • Oracle Enterprise Manager の Enterprise Manager Ops Center 11.1.3
  • Oracle Enterprise Manager の Enterprise Manager Ops Center 12.1.4
  • Oracle HTTP Server 10.1.3.5.0
  • Oracle HTTP Server 11.1.1.7.0
  • Oracle HTTP Server 12.1.2.0
  • Oracle HTTP Server 12.1.3.0
  • Oracle Virtualization の Oracle Secure Global Desktop 4.63
  • Oracle Virtualization の Oracle Secure Global Desktop 4.71
  • Oracle Virtualization の Oracle Secure Global Desktop 5.0
  • Oracle Virtualization の Oracle Secure Global Desktop 5.1
日立
  • Cosminexus Application Server Enterprise Version 6
  • Cosminexus Application Server Standard Version 6
  • Cosminexus Application Server Version 5
  • Cosminexus Developer Light Version 6
  • Cosminexus Developer Professional Version 6
  • Cosminexus Developer Standard Version 6
  • Cosminexus Developer Version 5
  • Cosminexus HTTP Server
  • Cosminexus Primary Server Base Version 6
  • Cosminexus Primary Server Version 6
  • Hitachi Web Server
  • Hitachi Web Server - Custom Edition
  • Hitachi Web Server - Security Enhancement
  • uCosminexus Application Server
  • uCosminexus Application Server Express
  • uCosminexus Application Server Standard-R
  • uCosminexus Application Server (64)
  • uCosminexus Application Server -R
  • uCosminexus Application Server Enterprise
  • uCosminexus Application Server Smart Edition
  • uCosminexus Application Server Standard
  • uCosminexus Developer
  • uCosminexus Developer 01
  • uCosminexus Developer Professional
  • uCosminexus Developer Professional for Plug-in
  • uCosminexus Developer Light
  • uCosminexus Developer Standard
  • uCosminexus Primary Server Base
  • uCosminexus Primary Server Base(64)
  • uCosminexus Service Architect
  • uCosminexus Service Platform
  • uCosminexus Service Platform (64)
  • uCosminexus Service Platform - Messaging

本脆弱性の影響を受ける日立製品の詳細については、ベンダ情報 HS15-013 をご確認ください。
想定される影響

第三者により、modules/generators/mod_status.c の status_handler 関数、および modules/lua/lua_request.c の lua_ap_scoreboard_worker 関数内での不適切なスコアボードの処理を誘発する巧妙に細工されたリクエストを介して、サービス運用妨害 (ヒープベースのバッファオーバーフロー) 状態にされる、重要な資格情報を取得される、または任意のコードを実行される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Apache Software Foundation アップル オラクル ターボリナックス レッドハット 日立
  • Hitachi Software Vulnerability Information : HS15-013
  • ソフトウェア製品セキュリティ情報 : HS15-013
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 競合状態(CWE-362) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-0226
参考情報

  1. JVN : JVNVU#91828320
  2. National Vulnerability Database (NVD) : CVE-2014-0226
  3. 関連文書 : MGASA-2014-0304
  4. 関連文書 : MGASA-2014-0305
更新履歴

[2014年07月22日]
  掲載
[2014年08月26日]
  ベンダ情報:レッドハット (RHSA-2014:1019) を追加
  ベンダ情報:レッドハット (RHSA-2014:1020) を追加
  ベンダ情報:レッドハット (RHSA-2014:1021) を追加
[2014年09月10日]
  参考情報:関連文書 (MGASA-2014-0304) を追加
[2014年10月06日]
  ベンダ情報:オラクル (Multiple Denial Of Service(DoS) vulnerabilities in Apache HTTP Server) を追加
[2015年01月22日]
  影響を受けるシステム:ベンダ情報の追加に伴い内容を更新
  ベンダ情報:オラクル (Oracle Critical Patch Update Advisory - January 2015) を追加
  ベンダ情報:オラクル (Text Form of Oracle Critical Patch Update - January 2015 Risk Matrices) を追加
  ベンダ情報:オラクル (January 2015 Critical Patch Update Released) を追加
[2015年04月10日]
  影響を受けるシステム:ベンダ情報の追加に伴い内容を更新
  ベンダ情報:アップル (HT204659) を追加
  ベンダ情報:アップル (APPLE-SA-2015-04-08-2 OS X 10.10.3 and Security Update 2015-004) を追加
  参考情報:JVN (JVNVU#91828320) を追加
[2015年04月22日]
  影響を受けるシステム:ベンダ情報の追加に伴い内容を更新
  ベンダ情報:日立 (HS15-013) を追加
[2015年04月30日]
  べンダ情報:ターボリナックス (TLSA-2015-9) を追加
[2015年05月11日]
  参考情報:関連文書 (MGASA-2014-0305) を追加