【活用ガイド】

JVNDB-2014-002391

PHP の FastCGI Process Manager の sapi/fpm/fpm/fpm_unix.c における権限を取得される脆弱性

概要

PHP の FastCGI Process Manager (FPM) の sapi/fpm/fpm/fpm_unix.c は、UNIX のソケットに対して 0666 パーミッションを使用するため、権限を取得される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 7.2 (危険) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


The PHP Group
  • PHP 5.4.28 未満
  • PHP 5.5.12 未満の 5.5.x
アップル
  • Apple Mac OS X 10.9 から 10.9.4

想定される影響

ローカルユーザにより、巧妙に細工された FastCGI クライアントを介して、権限を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

The PHP Group Ubuntu アップル
  • Apple Security Updates : HT6443
  • Apple セキュリティアップデート : HT6443
レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-0185
参考情報

  1. JVN : JVNVU#93868849
  2. National Vulnerability Database (NVD) : CVE-2014-0185
  3. 関連文書 : [PATCH] Fix bug #67060: use default mode of 660
更新履歴

[2014年05月08日]
  掲載
[2014年09月24日]
  影響を受けるシステム:ベンダ情報の追加に伴い内容を更新
  ベンダ情報:アップル (HT6443) を追加
  参考情報:JVN (JVNVU#93868849) を追加