【活用ガイド】

JVNDB-2014-001817

Adobe Flash Player におけるヒープベースのバッファオーバーフローの脆弱性

概要

Adobe Flash Player には、ヒープベースのバッファオーバーフローの脆弱性が存在します。

本脆弱性は、CanSecWest 2014 の Pwn2Own コンペティションにおいて実証されました。
CVSS による深刻度 (CVSS とは?)

基本値: 10.0 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


Google
  • Google Chrome 34.0.1847.137 未満 (Windows/Macintosh/Linux:Adobe Flash Player 13.0.0.214 未満)
アドビシステムズ
  • Adobe AIR SDK 13.0.0.111 未満 (Windows および Macintosh)
  • Adobe AIR SDK & Compiler 13.0.0.111 未満 (Windows および Macintosh)
  • Adobe Flash Player 11.2.202.359 未満 (Linux)
  • Adobe Flash Player 13.0.0.214 未満 (Windows 8.0 版の Internet Explorer 10)
  • Adobe Flash Player 13.0.0.214 未満 (Windows 8.1 版の Internet Explorer 11)
  • Adobe Flash Player 13.0.0.214 未満 (Windows および Macintosh)
  • Adobe Flash Player 13.0.0.214 未満 (Windows 版、Machintosh 版および Linux 版の Chrome)
マイクロソフト
  • Microsoft Internet Explorer 10 (Windows 8/Windows Server 2012/Windows RT:Adobe Flash Player 13.0.0.214 未満)
  • Microsoft Internet Explorer 11 (Windows 8.1/Windows Server 2012 R2/Windows RT 8.1:Adobe Flash Player 13.0.0.214 未満)

想定される影響

第三者により、任意のコードを実行される、およびサンドボックス保護メカニズムを回避される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Google アドビシステムズ マイクロソフト レッドハット 富士通
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-0510
参考情報

  1. National Vulnerability Database (NVD) : CVE-2014-0510
  2. IPA 重要なセキュリティ情報 : Adobe Flash Player の脆弱性対策についてAPSB14-14)(CVE-2014-0510等)
  3. JPCERT 注意喚起 : JPCERT-AT-2014-0022
  4. 警察庁 @police : アドビシステムズ社の Adobe Flash Player のセキュリティ修正プログラムについて(2014年05月14日)
  5. 関連文書 : Pwn2Own results for Thursday (Day Two)
更新履歴

[2014年03月28日]
  掲載
[2014年05月16日]
  影響を受けるシステム:内容を更新
  対策:内容を更新
  ベンダ情報:Google (Google Chrome) を追加
  ベンダ情報:Google (Stable Channel Update) を追加
  ベンダ情報:アドビシステムズ (APSB14-14) を追加
  ベンダ情報:マイクロソフト (Update for Vulnerabilities in Adobe Flash Player in Internet Explorer (2755801)) を追加
  ベンダ情報:マイクロソフト (Internet Explorer 上の Adobe Flash Player の脆弱性に対応する更新プログラム (2755801)) を追加
  ベンダ情報:富士通 (アドビ システムズ社 Adobe Flash Player の脆弱性に関するお知らせ) を追加
  参考情報:IPA セキュリティセンター 注意喚起 (Adobe Flash Player の脆弱性対策についてAPSB14-14)(CVE-2014-0510等)) を追加
  参考情報:JPCERT 注意喚起 (JPCERT-AT-2014-0022) を追加
  参考情報:警察庁 @police (アドビシステムズ社の Adobe Flash Player のセキュリティ修正プログラムについて(2014年05月14日)) を追加
[2014年06月04日]
  ベンダ情報:レッドハット (RHSA-2014:0496) を追加