【活用ガイド】

JVNDB-2014-001718

OpenSSH の sshd における環境による制限を回避される脆弱性

概要

OpenSSH の sshd は、sshd_config 内の AcceptEnv 行のワイルドカードを適切にサポートしないため、環境 (変数) による制限を回避される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 5.8 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


OpenBSD
  • OpenSSH 6.6 未満
アップル
  • Apple Mac OS X 10.6.8 以上 10.11 未満

想定される影響

第三者により、ワイルドカード文字の前に部分文字列を使用されることで、環境 (変数) による制限制限を回避される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

IBM OpenBSD アップル ヒューレット・パッカード レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-2532
参考情報

  1. JVN : JVNVU#97220341
  2. National Vulnerability Database (NVD) : CVE-2014-2532
更新履歴

[2014年03月19日]
  掲載
[2014年06月30日]
  ベンダ情報:IBM (AIX OpenSSH Vulnerability) を追加
[2014年11月26日]
  ベンダ情報:レッドハット (RHSA-2014:1552) を追加
[2014年12月08日]
  ベンダ情報:ヒューレット・パッカード (HPSBUX03188 SSRT101487) を追加
[2015年10月06日]
  影響を受けるシステム:ベンダ情報の追加に伴い内容を更新
  ベンダ情報:アップル (HT205267) を追加
  ベンダ情報:アップル (APPLE-SA-2015-09-30-3 OS X El Capitan 10.11) を追加
  参考情報:JVN (JVNVU#97220341) を追加