【活用ガイド】

[English]

JVNDB-2014-000035

SD Card Manager におけるディレクトリトラバーサルの脆弱性

概要

apps4u@android が提供する SD Card Manager には、ファイル名の処理に問題があり、ディレクトリトラバーサル (CWE-22) の脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: さくら情報システム株式会社 小池 亮平 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


apps4u@android
  • SD Card Manager

2014年2月24日より前に公開されたバージョンが本脆弱性の影響を受けます。
想定される影響

遠隔の第三者によって、アプリの権限でアクセス可能なディレクトリにおいて、ファイルを作成されたり既存のファイルを上書きされたりする可能性があります。
対策

[アップデートする]
2014年2月24日より前にダウンロードしたバージョンを使用している場合、開発者が提供する情報をもとに最新版へアップデートしてください。

ダウンロードされるソフトウェアのバージョンは、使用している Android OS のバージョンによって異なります。

また、開発者によると、Android OS 3.2 向けの SD Card Manager バージョン 2.5.6 では、本脆弱性の対応は行わないとのことです。
ベンダ情報

apps4u@android
CWEによる脆弱性タイプ一覧  CWEとは?

  1. パス・トラバーサル(CWE-22) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-1969
参考情報

  1. JVN : JVN#47386847
  2. National Vulnerability Database (NVD) : CVE-2014-1969
更新履歴

[2014年04月11日]
  掲載
[2014年04月16日]
  参考情報:National Vulnerability Database (NVD) (CVE-2014-1969) を追加