【活用ガイド】

JVNDB-2013-003349

PHP の ext/xml/xml.c におけるサービス運用妨害 (DoS) の脆弱性

概要

PHP の ext/xml/xml.c は、構文解析の深さを適切に考慮しないため、サービス運用妨害 (ヒープメモリの破損) 状態にされるなどの不特定の影響を受ける脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


The PHP Group
  • PHP 5.3.27 未満
アップル
  • Apple Mac OS X v10.7.5
  • Apple Mac OS X v10.8.5
  • Apple Mac OS X v10.9
  • Apple Mac OS X v10.9.1
  • Apple Mac OS X Server v10.7.5

想定される影響

第三者により、xml_parse_into_struct 関数によって処理される巧妙に細工されたドキュメントを介して、サービス運用妨害 (ヒープメモリの破損) 状態にされるなどの不特定の影響を受ける可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Debian Novell The PHP Group Ubuntu アップル オラクル レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2013-4113
参考情報

  1. JVN : JVNVU#95868425
  2. National Vulnerability Database (NVD) : CVE-2013-4113
更新履歴

[2013年07月16日]
  掲載
[2013年08月27日]
  ベンダ情報:レッドハット (RHSA-2013:1063) を追加
  ベンダ情報:レッドハット (RHSA-2013:1061) を追加
  ベンダ情報:Debian (DSA-2723) を追加 
  ベンダ情報:Novell (SUSE-SU-2013:1316) を追加
  ベンダ情報:Ubuntu (USN-1905-1) を追加
[2013年09月04日]
  ベンダ情報:レッドハット (RHSA-2013:1062) を追加
[2014年02月28日]
  影響を受けるシステム:アップル (HT6150) の情報を追加
  ベンダ情報:アップル (APPLE-SA-2014-02-25-1) を追加
  ベンダ情報:アップル (HT6150) を追加
  参考情報:JVN (JVNVU#95868425) を追加
[2014年04月07日]
  ベンダ情報:オラクル (Multiple vulnerabilities in PHP) を追加
  ベンダ情報:オラクル (CVE-2013-4113 Buffer Errors vulnerability in PHP) を追加