【活用ガイド】

JVNDB-2013-002247

phpMyAdmin の tbl_gis_visualization.php におけるクロスサイトスクリプティングの脆弱性

概要

phpMyAdmin の tbl_gis_visualization.php には、クロスサイトスクリプティングの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


The phpMyAdmin Project
  • phpMyAdmin 3.58 未満の 3.5x

想定される影響

第三者により、(1) visualizationSettings[width] または (2) visualizationSettings[height] パラメータを介して、任意の Web スクリプトまたは HTML を挿入される可能性があります。
対策

ベンダ情報および参考情報を参照して適切な対策を実施してください。
ベンダ情報

Fedora Project Mandriva, Inc. Novell The phpMyAdmin Project
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2013-1937
参考情報

  1. National Vulnerability Database (NVD) : CVE-2013-1937
更新履歴

[2013年04月17日]
  掲載
[2013年07月05日]
  ベンダ情報:The phpMyAdmin Project (PMASA-2013-1) を追加
  ベンダ情報:Novell (openSUSE-SU-2013:1065) を追加
[2013年12月05日]
  ベンダ情報:Fedora Project (FEDORA-2013-5620) を追加
  ベンダ情報:Fedora Project (FEDORA-2013-5623) を追加
  ベンダ情報:Fedora Project (FEDORA-2013-5604) を追加
  ベンダ情報:Mandriva, Inc. (MDVSA-2013:144) を追加