【活用ガイド】

JVNDB-2012-003240

PHP の stream の実装における脆弱性

概要

PHP に stream を実装する _php_stream_scandir 関数には、不特定の影響を受ける脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 10.0 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


The PHP Group
  • PHP 5.4.5 未満の 5.4.x
  • PHP 5.3.15 未満
アップル
  • Apple Mac OS X v10.6.8
  • Apple Mac OS X v10.7 から v10.7.4
  • Apple Mac OS X v10.8
  • Apple Mac OS X v10.8.1
  • Apple Mac OS X Server v10.6.8
  • Apple Mac OS X Server v10.7 から v10.7.4

想定される影響

不特定の影響を受ける可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Debian
  • Debian セキュリティ勧告 : DSA-2527
Novell The PHP Group Ubuntu アップル オラクル レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2012-2688
参考情報

  1. JVN : JVNVU#381963
  2. National Vulnerability Database (NVD) : CVE-2012-2688
更新履歴

[2012年07月23日]
  掲載
[2012年09月14日]
  ベンダ情報:openSUSE (openSUSE-SU-2012:0976) を追加
  ベンダ情報:openSUSE (SUSE-SU-2012:1034) を追加
  ベンダ情報:openSUSE (SUSE-SU-2012:1033) を追加
  ベンダ情報:Debian (DSA-2527) を追加
[2012年10月16日]
  ベンダ情報:アップル (HT5501) を追加
[2012年10月22日]
  ベンダ情報:Ubuntu (USN-1569-1) を追加
[2014年02月06日]
  影響を受けるシステム:アップル (HT5501) の情報を追加
  ベンダ情報:アップル (APPLE-SA-2012-09-19-2) を追加
  ベンダ情報:レッドハット (RHSA-2013:1307) を追加
[2014年04月07日]
  ベンダ情報:オラクル (Multiple vulnerabilities in PHP) を追加