【活用ガイド】

[English]

JVNDB-2012-000089

ATOK for Android における学習情報ファイルのアクセス権限に関する問題

概要

ジャストシステムが提供する ATOK for Android には、学習情報ファイルのアクセス権限に関する問題が存在します。

ジャストシステムが提供する ATOK for Android には、他のアプリケーションから、ユーザが入力した文字列を保存している学習情報ファイルにアクセス可能な問題が存在します。

この情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 三井物産セキュアディレクション株式会社 望月 岳 氏

CVSS による深刻度 (CVSS とは?)

基本値: 2.6 (注意) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし

影響を受けるシステム


ジャストシステム
  • ATOK for Android バージョン 1.0.4 より前のバージョン

開発者によると、バージョン情報は以下の手順で確認できるとのことです。

    【バージョン番号の確認手順】
    文字入力画面で「あA1」をロングタッチして、
    ATOKメニュー → 「ATOKの設定」をタップします。
    最下位行に表示されるバージョン情報を確認します。

    日本語入力システム ATOK
    Ver.1.X.X ← この数字がバージョン番号
    (C)2012 株式会社ジャストシステム

    ※ Ver.1.0.4以降であれば、この問題は解決されています。

想定される影響

ユーザが、不正な他の Android アプリケーションを使用した場合、学習情報ファイルを取得される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

ジャストシステム
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2012-4016
参考情報

  1. JVN : JVN#93344001
  2. National Vulnerability Database (NVD) : CVE-2012-4016
更新履歴

[2012年09月25日]
  掲載