【活用ガイド】

[English]

JVNDB-2012-000066

Ruby のハッシュ関数の実装におけるサービス運用妨害 (DoS) の脆弱性

概要

Ruby のハッシュ関数の実装には、サービス運用妨害 (DoS) の脆弱性が存在します。

Ruby のハッシュ関数の実装には、同一のハッシュ値となる複数の異なる文字列を容易に作成可能な問題が存在します。結果として、サービス運用妨害 (DoS) 攻撃を受ける可能性があります。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 産業技術総合研究所 情報技術研究部門 田中 哲 氏

CVSS による深刻度 (CVSS とは?)

基本値: 5.0 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): なし
  • 可用性への影響(A): 部分的

影響を受けるシステム


Ruby-lang.org
  • Ruby 1.8.7-p357 より前のバージョン
  • Ruby 1.9.1 より前の 1.9 系

想定される影響

Ruby で実装されたアプリケーションが細工された入力を大量に処理することで、サービス運用妨害 (DoS) 攻撃を受ける可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版にアップデートしてください。
ベンダ情報

Ruby-lang.org アップル
  • Apple Security Updates : HT5281
オラクル
CWEによる脆弱性タイプ一覧  CWEとは?

  1. リソース管理の問題(CWE-399) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2011-4815
参考情報

  1. JVN : JVN#90615481
  2. JVN : JVNVU#903934
  3. JVN : JVNVU#692779
  4. National Vulnerability Database (NVD) : CVE-2011-4815
  5. US-CERT Vulnerability Note : VU#903934
  6. IPA 緊急対策情報 : 20120106-web
更新履歴

[2012年07月06日]
  掲載