【活用ガイド】

[English]

JVNDB-2012-000045

Drupal の Form API における送信先 URL を検証しない脆弱性

概要

Drupal の Form API には、送信先の URL を検証しない脆弱性が存在します。

Drupal は、コンテンツ管理システム (CMS) です。Drupal の Form API には、送信先 の URL を検証しない脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: NECネクサソリューションズ株式会社 中西 克彦 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


Drupal
  • Drupal core 7.x 系の 7.13 より前のバージョン

想定される影響

遠隔の第三者によって、フォームの送信先を変更される可能性があります。結果として、認証情報などを窃取される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

Drupal
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 不適切な入力確認(CWE-20) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2012-1589
参考情報

  1. JVN : JVN#45898075
  2. National Vulnerability Database (NVD) : CVE-2012-1589
更新履歴

[2012年05月17日]
  掲載