【活用ガイド】

JVNDB-2011-005032

Samba の RPC コードジェネレータにおける任意のコードを実行される脆弱性

概要

Samba の RPC コードジェネレータは、配列のメモリ割り当ての検証と一貫性のある方法で、配列の長さの検証を実装していないため、任意のコードを実行される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 10.0 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


Samba Project
  • Samba 3.4.16 未満の 3.x
  • Samba 3.5.14 未満の 3.5.x
  • Samba 3.6.4 未満の 3.6.x

想定される影響

第三者により、巧妙に細工された RPC コールを介して、任意のコードを実行される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Fedora Project Samba Project Ubuntu アップル
  • Apple Security Updates : HT5281
オラクル レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 数値処理の問題(CWE-189) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2012-1182
参考情報

  1. JVN : JVNVU#692779
  2. National Vulnerability Database (NVD) : CVE-2012-1182
更新履歴

[2012年04月12日]
  掲載
[2012年05月14日]
  ベンダ情報:アップル (HT5281) を追加
[2012年05月18日]
  ベンダ情報:オラクル (CVE-2012-1182 Arbitrary code execution vulnerability in Samba) を追加
[2012年09月05日]
  ベンダ情報:Ubuntu (USN-1423-1) を追加
  ベンダ情報:Fedora Project (FEDORA-2012-6382) を追加