【活用ガイド】

[English]

JVNDB-2011-000069

Sage において任意のスクリプトが実行される脆弱性

概要

Sage には任意のスクリプトが実行される脆弱性が存在します。
なお、本脆弱性は JVN#99203127 とは異なる問題です。

Sage は、Mozilla Firefox に RSS/Atom フィードリーダー機能を追加する機能拡張です。Sage には、フィード内の情報を HTML ページに出力する際の処理が不適切なため、ユーザのブラウザ上でフィードに埋め込まれた任意のスクリプトが実行される脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: ネットエージェント株式会社 長谷川陽介 氏

CVSS による深刻度 (CVSS とは?)

基本値: 5.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


Sage
  • Sage 1.3.10 およびそれ以前

想定される影響

Sage を利用しているユーザの Mozilla Firefox 上で任意のスクリプトが実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。

[ワークアラウンドを実施する]
アップデートを適用するまでの間、以下のワークアラウンドを実施することで、本脆弱性の影響を回避することが可能です。

* Sage の設定にて「コンテンツエリアにフィードを読み込む」のチェックを外す
ベンダ情報

Mozilla Foundation
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2011-3384
参考情報

  1. JVN : JVN#30221194
  2. National Vulnerability Database (NVD) : CVE-2011-3384
更新履歴

[2011年09月02日]
  掲載