【活用ガイド】

[English]

JVNDB-2011-000053

Android における SSL 証明書の表示に関する脆弱性

概要

Android には、SSL 証明書の表示に関する脆弱性が存在します。

Android には、外部サイトのコンテンツを読み込むウェブサイトの SSL 証明書を表示する際、外部サイトの SSL 証明書を表示してしまう脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社ビジネスインフォーメイションガーヴァン 大谷 周平 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


Google
  • Android 2.2 より前のバージョン

想定される影響

安全なサイトにアクセスしていると誤認してしまい、フィッシング詐欺などの被害を受ける可能性があります。
対策

[モバイル端末開発者向けの対策]
Google が提供する情報をもとにアップデートを行ってください。

[モバイル端末ユーザ向けの対策]
詳しくは、下記 「ベンダ情報」 をご確認ください。

なお、本脆弱性は Android OS 2.2 で対策されています。
ベンダ情報

Google パナソニック株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2010-4832
参考情報

  1. JVN : JVN#43105011
  2. National Vulnerability Database (NVD) : CVE-2010-4832
  3. 関連文書 : b/2511635 Browser displays incorrect SSL cert information
更新履歴

[2011年07月29日]
  掲載
[2011年08月15日]
  ベンダ情報:パナソニック株式会社 (ソフトウェアダウンロード) を追加
[2014年05月19日]
  参考情報:National Vulnerability Database (NVD) (CVE-2010-4832) を追加
  参考情報:関連文書 (b/2511635 Browser displays incorrect SSL cert information) を追加