【活用ガイド】

[English]

JVNDB-2011-000008

MODx Evolution における SQL インジェクションの脆弱性

概要

MODx Evolution には、SQL インジェクションの脆弱性が存在します。

MODx Evolution は、Modx CMS Project が提供するコンテンツ管理システム (CMS) です。MODx Evolution には、SQL インジェクションの脆弱性が存在します。

CVSS による深刻度 (CVSS とは?)

基本値: 7.5 (危険) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


MODX
  • MODX Evolution 1.0.4 およびそれ以前

想定される影響

遠隔の第三者によって、HTTP リクエスト経由でデータベースを操作される可能性があります。その結果、任意の PHP プログラムを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。

なお、本脆弱性は以下のバージョンで修正されています。
* MODx Evolution 1.0.5
ベンダ情報

MODX
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2010-3929
参考情報

  1. JVN : JVN#54092716
  2. National Vulnerability Database (NVD) : CVE-2010-3929
  3. IPA 重要なセキュリティ情報 : 「MODx Evolution」におけるセキュリティ上の弱点(脆弱性)の注意喚起
  4. ISS X-Force Database : 65082
  5. OPEN SOURCE VULNERABILITY DATABASE (OSVDB) : 70771
更新履歴

[2011年01月26日]
 掲載