【活用ガイド】

JVNDB-2010-004301

WordPress の xmlrpc.php におけるアクセス制限を回避される脆弱性

概要

WordPress の xmlrpc.php 内の XML-RPC リモートパブリッシングインターフェースは、機能のチェックを適切に行わないため、アクセス制限を回避され、投稿を公開、編集、または削除される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 6.5 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


WordPress.org
  • WordPress 3.0.3 未満

想定される影響

リモート認証されたユーザにより、作者 (Author) または投稿者 (Contributor) ロールを利用されることで、アクセス制限を回避され、投稿を公開、編集、または削除される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

WordPress.org
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2010-5106
参考情報

  1. National Vulnerability Database (NVD) : CVE-2010-5106
更新履歴

[2012年09月19日]
  掲載