【活用ガイド】

[English]

JVNDB-2010-000054

Flash Player におけるアクセス制限回避の脆弱性

概要

Flash Player には、アクセス制限回避が可能な脆弱性が存在します。

Flash Player が、Flash コンテンツが設置されているウェブサイトとは別のウェブサイトを参照する場合、参照されるウェブサイトがクロスドメインポリシーファイルによりアクセスを許可している必要があります。

Flash Player には、クロスドメインポリシーファイルによるアクセス制限が回避される脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社シマンテック コンサルティングサービス本部 赤嶺徳治 氏

CVSS による深刻度 (CVSS とは?)

基本値: 2.6 (注意) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし

影響を受けるシステム


アップル
  • Apple Mac OS X v10.5.8
  • Apple Mac OS X v10.6 から v10.6.4
  • Apple Mac OS X Server v10.5.8
  • Apple Mac OS X Server v10.6 から v10.6.4
アドビシステムズ
  • Adobe Flash Player 10.1.85.3 およびそれ以前の Windows 版、Macintosh 版、Linux 版、Solaris 版
  • Adobe Flash Player 10.1.95.2 およびそれ以前の Android 版
オラクル
  • Oracle Solaris 10
  • Oracle Solaris 11 Express
レッドハット
  • Red Hat Enterprise Linux Desktop Supplementary (v. 6)
  • Red Hat Enterprise Linux Extras (v.4)
  • Red Hat Enterprise Linux Extras (v.4.8.z) 
  • Red Hat Enterprise Linux Server Supplementary (v. 6)
  • Red Hat Enterprise Linux Workstation Supplementary (v. 6)
  • RHEL Desktop Supplementary (v. 5 client)
  • RHEL Supplementary (v.5 server)

想定される影響

細工されたウェブページにより、ウェブサイトのクロスドメインポリシーが迂回される可能性があります。この結果、ウェブサイト管理者の意図に反してデータにアクセスされる可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。
ベンダ情報

アップル
  • Apple Security Updates : HT4435
  • Apple セキュリティアップデート : HT4435
アドビシステムズ オラクル レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2010-3636
参考情報

  1. JVN : JVN#48425028
  2. JVN : JVNVU#331391
  3. National Vulnerability Database (NVD) : CVE-2010-3636
  4. Secunia Advisory : SA42183
  5. SecurityFocus : 44691
  6. VUPEN Security : VUPEN/ADV-2010-2903
  7. VUPEN Security : VUPEN/ADV-2010-2906
  8. VUPEN Security : VUPEN/ADV-2010-2918
更新履歴

[2010年11月09日]
  掲載
[2010年12月03日]
  影響を受けるシステム:アップル (HT4435) の情報を追加
  影響を受けるシステム:レッドハット (RHSA-2010:0829) の情報を追加
  影響を受けるシステム:レッドハット (RHSA-2010:0834) の情報を追加
  影響を受けるシステム:レッドハット (RHSA-2010:0867) の情報を追加
  ベンダ情報:アップル (HT4435) を追加
  ベンダ情報:レッドハット (RHSA-2010:0829) を追加
  ベンダ情報:レッドハット (RHSA-2010:0834) を追加
  ベンダ情報:レッドハット (RHSA-2010:0867) を追加
[2011年02月01日]
  影響を受けるシステム:オラクル (multiple_vulnerabilities_in_adobe_flash1) の情報を追加
  ベンダ情報:オラクル (multiple_vulnerabilities_in_adobe_flash1) を追加