【活用ガイド】

[English]

JVNDB-2009-003901

Cacti におけるクロスサイトスクリプティングの脆弱性

概要

Cacti には、以下に関連する処理に不備があるため、クロスサイトスクリプティングの脆弱性が存在します。

(1) graph.php
(2) include/top_graph_header.php
(3) lib/html_form.php
(4) lib/timespan_settings.php

この脆弱性は、以下のパラメータを介した処理で実証されています。

(a) graph.php の graph_end パラメータ
(b) graph.php の graph_start パラメータ
(c) graph_view.php の action=tree 時の date1 パラメータ
(d) graph_settings.php の page_refresh パラメータ
(e) graph_settings.php の default_dual_pane_width パラメータ
CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


The Cacti Group
  • Cacti 0.8.7e およびそれ以前

想定される影響

第三者により、任意の Web スクリプトまたは HTML を挿入される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

The Cacti Group
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2009-4032
参考情報

  1. JVN : JVN#09758120
  2. National Vulnerability Database (NVD) : CVE-2009-4032
更新履歴

[2012年06月26日]
  掲載
[2015年07月09日]
  JVN#09758120 にあわせ、概要、影響を受けるシステム、参考情報を更新