【活用ガイド】

[English]

JVNDB-2009-000050

MySQL Connector/J における SQL インジェクションの脆弱性

概要

Sun Microsystems が提供する MySQL Connector/J には、SQL インジェクションの脆弱性が存在します。

Sun Microsystems が提供する MySQL Connector/J は、MySQL データベースにアクセスするための Java 言語用ドライバソフトウェアです。MySQL Connector/J には、SQL インジェクションの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC がベンダとの調整を行いました。
報告者: WebAppSec 池田 雅一 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


サン・マイクロシステムズ
  • MySQL Connector/J 5.1.7 およびそれ以前

想定される影響

遠隔の第三者によって、データベース内のコンテンツを取得されたり、改ざんされたりする可能性があります。
対策

[アップデートする]
Sun Microsystems が提供する情報をもとに最新版へアップデートしてください。
ベンダ情報

サン・マイクロシステムズ
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

参考情報

  1. JVN : JVN#59748723
更新履歴

[2009年07月29日]
  掲載