【活用ガイド】

[English]

JVNDB-2009-000004

MODx におけるクロスサイトリクエストフォージェリの脆弱性

概要

オープンソースのコンテンツ管理システムである MODx には、クロスサイトリクエストフォージェリの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者:三井物産セキュアディレクション株式会社 望月 岳 氏

CVSS による深刻度 (CVSS とは?)

基本値: 2.6 (注意) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


MODX
  • MODX 0.9.6.1p2 およびそれ以前

想定される影響

当該製品にログインした状態で、悪意あるページを読み込んだ場合、意図せず MODx のコンテンツが編集される可能性があります。
対策

[最新版にアップデートし、設定変更を行なう]
開発者が提供する情報をもとに最新版へアップデートし、さらに以下の設定を行なってください。

  * MODx の管理画面にログイン後、Referer チェックのデフォルト設定
   [いいえ] を [はい] に変更する

[ワークアラウンドを実施する]
Referer チェックの設定変更を行えない場合は、以下のワークアラウンドを実施することで、この脆弱性の影響を軽減することが可能です。

  * ログイン中は信用できないリンクをクリックしない
  * 作業が終了後は速やかにログアウトする

詳しくは開発者が提供する情報をご確認ください。
ベンダ情報

MODX
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトリクエストフォージェリ(CWE-352) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2008-5941
参考情報

  1. JVN : JVN#66828183
  2. National Vulnerability Database (NVD) : CVE-2008-5941
  3. JVN iPedia (English) : JVNDB-2009-000004
更新履歴

[2009年01月09日]
  掲載