【活用ガイド】

JVNDB-2008-001095

Adobe Reader および Adobe Acrobat の JavaScript メソッドにおけるバッファオーバーフローの脆弱性

概要

Adobe Reader および Adobe Acrobat は、Portable Document Format (PDF) ドキュメントを閲覧したりするためのソフトウェアです。Adobe Reader および Adobe Acrobat にはバッファオーバーフローの脆弱性が存在します。

Adobe Reader および Adobe Acrobat は、Portable Document Format (PDF) ドキュメントを閲覧したりするためのソフトウェアです。Adobe Reader や Adobe Acrobat のいくつかの JavaScript メソッドには、入力値を適切に処理できないためバッファオーバーフローの脆弱性が存在します。

また、本脆弱性をついた活動に関する情報も公開されています。
CVSS による深刻度 (CVSS とは?)

基本値: 9.3 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


アドビシステムズ
  • Adobe Acrobat Professional 8.1.1 およびそれ以前
  • Adobe Acrobat 3D 8.1.1 およびそれ以前
  • Adobe Acrobat Standard 8.1.1 およびそれ以前
  • Adobe Reader 8.1.1 およびそれ以前
サン・マイクロシステムズ
  • Sun Solaris 10 (SPARC)
レッドハット
  • Red Hat Enterprise Linux Extras (v.3)
  • Red Hat Enterprise Linux Extras (v.4)
  • RHEL Desktop Supplementary (v. 5 client)
  • RHEL Supplementary (v.5 server)

想定される影響

遠隔の第三者によって細工されたウェブページコンテンツや E-mail に添付されたファイルを閲覧することによって任意のコードを実行される可能性があります。

また、Adobe Acrobat プラグインなどを使用している場合も影響を受ける可能性があります。
対策

アップデートする
Adobe が提供する本件への対応を含めたセキュリティアップデート APSA08-01 を確認の上最新版を適用してください。

また、Adobe Reader や Adobe Acrobat の 7.0.9 およびそれ以前を利用しているユーザは対策版が公開されるまで以下の回避策を行うことをで想定される影響を軽減することができます。

・ウェブブラウザ上での PDF ドキュメントの表示を無効にする
・JavaScript を無効にする
・信頼できない PDF ファイルを開かない
ベンダ情報

アドビシステムズ サン・マイクロシステムズ
  • Sun Alert Notification : 239286
レッドハット 富士通
  • 富士通 セキュリティ情報 : TA08-043A
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2007-5659
参考情報

  1. JVN : JVNTA08-043A
  2. JVN : JVNVU#666281
  3. JVN Status Tracking Notes : TRTA08-043A
  4. National Vulnerability Database (NVD) : CVE-2007-5659
  5. US-CERT Cyber Security Alerts : SA08-043A
  6. US-CERT Vulnerability Note : VU#666281
  7. US-CERT Technical Cyber Security Alert : TA08-043A
  8. SecurityFocus : 27641
  9. FrSIRT Advisories : FrSIRT/ADV-2008-0425
更新履歴

[2008年02月26日]
  掲載
[2008年05月21日]
  影響を受けるシステム:アドビシステムズ (APSB08-13) の情報を追加
  ベンダ情報: アドビシステムズ (APSB08-13) を追加
[2008年07月09日]
  影響を受けるシステム:サン・マイクロシステムズ(239286) の情報を追加
  ベンダ情報:サン・マイクロシステムズ(239286) を追加