【活用ガイド】

[English]

JVNDB-2008-000074

Snoopy における OS コマンドインジェクションの脆弱性

概要

PHP ライブラリである Snoopy には、OS コマンドインジェクションの脆弱性が存在します。

Snoopy はオープンソースの PHP ライブラリです。Snoopy には入力内容の処理が適正に行われないため、OS コマンドインジェクションの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC がベンダとの調整を行いました。
報告者:三井物産セキュアディレクション 寺田 健 氏

CVSS による深刻度 (CVSS とは?)

基本値: 5.1 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


Snoopy
  • Snoopy 1.2.3 およびそれ以前
Usagi Project
  • MyNETS 1.2.0.1以前
  • MyNETS 1.1.1+20081020以前
  • MyNETS 1.1.0+20081020以前
  • MyNETS 1.0.1+20081020以前
  • MyNETS 1.0.0+20081020以前

想定される影響

Snoopy を設置し実行可能にしているサーバ上で、サーバの権限で任意の OS コマンドを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。
ベンダ情報

Snoopy Usagi Project
CWEによる脆弱性タイプ一覧  CWEとは?

  1. OSコマンドインジェクション(CWE-78) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2008-4796
参考情報

  1. JVN : JVN#20502807
  2. National Vulnerability Database (NVD) : CVE-2008-4796
  3. Secunia Advisory : SA32361
  4. FrSIRT Advisories : FrSIRT/ADV-2008-2901
  5. JVN iPedia (English) : JVNDB-2008-000074
更新履歴

[2008年10月28日]
  掲載
[2008年11月28日]
  影響を受けるシステム:Usagi Project(MyNETSで利用している外部ライブラリSnoopyに脆弱性)の情報を追加
  ベンダ情報:Usagi Project(MyNETSで利用している外部ライブラリSnoopyに脆弱性)を追加