【活用ガイド】

[English]

JVNDB-2008-000031

CGIWrap のエラー画面におけるクロスサイトスクリプティングの脆弱性

概要

CGIWrap のエラー画面には、クロスサイトスクリプティングの脆弱性が存在します。

CGIWrap は、ウェブサーバ上で CGI をユーザ権限で実行するためのオープンソースのラッパープログラムです。CGIWrap が出力するエラー画面には、クロスサイトスクリプティングの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC がベンダとの調整を行いました。
報告者:ネットエージェント株式会社 山口 尋久 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


CGIWrap
  • CGIWrap 4.0 およびそれ以前

想定される影響

ユーザのブラウザ上で任意のスクリプトを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。
ベンダ情報

CGIWrap
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2008-2852
参考情報

  1. JVN : JVN#45389864
  2. National Vulnerability Database (NVD) : CVE-2008-2852
  3. Secunia Advisory : SA30765
  4. SecurityFocus : 29811
  5. ISS X-Force Database : 43176
更新履歴

[2008年06月19日]
  掲載