【活用ガイド】

[English]

JVNDB-2008-000030

BlognPlus(ぶろぐん+) における SQL インジェクションの脆弱性

概要

BlognPlus(ぶろぐん+) には、SQL インジェクションの脆弱性が存在します。

R-ONE コンピューターが提供する BlognPlus(ぶろぐん+) は、ブログ作成用のソフトウェアです。BlognPlus(ぶろぐん+) の MySQL 版および PostgreSQL版には、SQL インジェクションの脆弱性が存在します。

製品開発者によると、BlognPlus(ぶろぐん+) の Text 版はデータベースを使用していないため、SQL インジェクションによる影響はありません。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC がベンダとの調整を行いました。
報告者: 内藤 秀幸 氏

CVSS による深刻度 (CVSS とは?)

基本値: 7.5 (危険) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


R-ONE コンピューター
  • BlognPlus(ぶろぐん+) v2.5.4 およびそれ以前の MySQL 版、またはPostgreSQL 版

想定される影響

遠隔の第三者が、BlognPlus(ぶろぐん+) で作成されたブログの管理者権限を取得する可能性があります。
対策

[アップデートする]
ベンダが提供する情報をもとに最新版へアップデートしてください。
ベンダ情報

R-ONE コンピューター
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2008-2819
参考情報

  1. JVN : JVN#14072646
  2. National Vulnerability Database (NVD) : CVE-2008-2819
更新履歴

[2008年06月17日]
  掲載