【活用ガイド】

JVNDB-2006-000441

Apache HTTP Server の Expect リクエストヘッダにおけるクロスサイトスクリプティングの脆弱性

概要

Apache HTTP Server には、 Expect リクエストヘッダをエラーページに出力する際に適切にエスケープ処理が行われないため、スクリプト文が挿入された Expect リクエストヘッダに対して 417 Expectation Failed エラーページを出力した場合、挿入されたスクリプトが実行されてしまう脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


Apache Software Foundation
  • Apache HTTP Server 1.3.34 およびそれ以前
  • Apache HTTP Server 2.0.55 およびそれ以前
  • Apache HTTP Server 2.2.0
IBM
  • IBM HTTP Server 2.0.42.2 およびそれ以前
  • IBM HTTP Server 2.0.47.1 およびそれ以前
  • IBM HTTP Server 6.0.2.11 およびそれ以前
  • IBM HTTP Server 6.1
ターボリナックス
  • Turbolinux 10 Server
  • Turbolinux 10 Server x64 Edition
  • Turbolinux 7 Server
  • Turbolinux 8 Server
ヒューレット・パッカード
  • HP-UX 11.11
  • HP-UX 11.23
  • HP-UX 11.31
ミラクル・リナックス
  • MIRACLE LINUX V3.0
  • MIRACLE LINUX V3.0 for x86-64
  • MIRACLE LINUX V4.0
  • MIRACLE LINUX V4.0 for x86-64
レッドハット
  • Red Hat Enterprise Linux AS (v.2.1)
  • Red Hat Enterprise Linux AS (v.3)
  • Red Hat Enterprise Linux AS (v.4)
  • Red Hat Enterprise Linux ES (v.2.1)
  • Red Hat Enterprise Linux ES (v.3)
  • Red Hat Enterprise Linux ES (v.4)
  • Red Hat Enterprise Linux WS (v.2.1)
  • Red Hat Enterprise Linux WS (v.3)
  • Red Hat Enterprise Linux WS (v.4)
日立
  • Cosminexus Application Server Enterprise Version 6
  • Cosminexus Application Server Standard Version 6
  • Cosminexus Application Server Version 5
  • Cosminexus Developer Light Version 6
  • Cosminexus Developer Professional Version 6
  • Cosminexus Developer Standard Version 6
  • Cosminexus Developer Version 5
  • Cosminexus Server - Enterprise Edition
  • Cosminexus Server - Standard Edition
  • Cosminexus Server - Standard Edition Version 4
  • Cosminexus Server - Web Edition
  • Cosminexus Server - Web Edition Version 4
  • Hitachi Web Server
  • Hitachi Web Server - Custom Edition
  • Hitachi Web Server - Security Enhancement
  • Hitachi Web Server for VOS3
  • uCosminexus Application Server Enterprise
  • uCosminexus Application Server Smart Edition
  • uCosminexus Application Server Standard
  • uCosminexus Developer Professional
  • uCosminexus Developer Light
  • uCosminexus Developer Standard
  • uCosminexus Service Architect
  • uCosminexus Service Platform

本脆弱性の影響を受ける日立製品の詳細については、ベンダ情報 HS06-022 をご確認ください。
想定される影響

ユーザのブラウザ上で任意のスクリプトを実行される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Apache Software Foundation
  • Apache httpd 1.3 vulnerabilities : 1.3.35
IBM ターボリナックス ヒューレット・パッカード ミラクル・リナックス
  • MIRACLE LINUX アップデート情報 : 428
レッドハット 日立
  • Hitachi Software Vulnerability Information : HS06-022
  • ソフトウェア製品セキュリティ情報 : HS06-022
CWEによる脆弱性タイプ一覧  CWEとは?

共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2006-3918
参考情報

  1. National Vulnerability Database (NVD) : CVE-2006-3918
  2. Secunia Advisory : SA21172
  3. FrSIRT Advisories : FrSIRT/ADV-2006-2963
更新履歴

[2007年04月01日]
  掲載
[2009年11月13日]
  影響を受けるシステム:ヒューレット・パッカード (HPSBUX02465) の情報を追加
  ベンダ情報:ヒューレット・パッカード (HPSBUX02465) を追加
[2010年12月20日]
  ベンダ情報:ヒューレット・パッカード (HPSBUX02612) を追加
[2014年05月22日]
  影響を受けるシステム:日立 (HS06-022) の情報を追加
  ベンダ情報:日立 (HS06-022) を追加