[Japanese]

JVNDB-2014-000019

AutoCAD vulnerable to arbitrary VBScript execution

Overview

AutoCAD provided by Autodesk, Inc. is an application for comuputer-aided design (CAD). AutoCAD loads specific FAS files when opening files. AutoCAD contains an issue with the FAS file search path, which may lead to arbitrary VBScript code execution.

kaito834 reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


Autodesk, Inc.
  • AutoCAD 2013 and earlier

Impact

Arbitrary VBScript code may be executed with the privilege of the application.
Solution

[Upgrade the Software]
Upgrade to the latest version according to the information provided by the developer.

According to the developer, this issue was resolved in AutoCAD 2014.
Vendor Information

Autodesk, Inc.
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2014-0818
References

  1. JVN : JVN#33382534
  2. National Vulnerability Database (NVD) : CVE-2014-0818
Revision History

[2014/02/21]
  Web page was published
[2014/02/25]
  References : Content was added