[Japanese]

JVNDB-2014-000009

OpenPNE vulnerable to PHP Object Injection

Overview

OpenPNE contains an issue in processing Cookie headers, which may result in a PHP Object Injection vulnerability.

Egidio Romano of Secunia reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


OpenPNE
  • OpenPNE 3.6.13 and earlier
  • OpenPNE 3.8.9 and earlier

Impact

A remote, unauthenticated attacker may execute an arbitrary PHP code.
Solution

[Apply an update]
Update to the latest version according to the information provided by the developer.
Vendor Information

OpenPNE
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2013-5350
References

  1. JVN : JVN#69986880
  2. National Vulnerability Database (NVD) : CVE-2013-5350
  3. IPA SECURITY ALERTS : Security Alert for OpenPNE vulnerable to PHP Object Injection (JVN#69986880) (in Japanese)
  4. Related Information : Secunia Advisory SA54043 OpenPNE PHP Object Injection Vulnerability
Revision History

[2014/01/24]
  Web page was published
[2014/01/28]
  References : Content was added