【活用ガイド】

[English]

JVNDB-2020-000038

Zenphoto における複数の脆弱性

概要

Zenphoto はコンテンツ管理システム (CMS) です。Zenphoto には次の複数の脆弱性が存在します。
・クロスサイトスクリプティング (CWE-79) - CVE-2020-5592
・コードインジェクション (CWE-94) - CVE-2020-5593

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者:パナソニック株式会社 製品セキュリティセンター 前田 朋久 氏
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 8.8 (重要) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
CVSS v2 による深刻度
基本値: 6.5 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的
※上記は、CVE-2020-5593の評価になります。


CVSS v3 による深刻度
基本値: 6.1 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更あり
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
※上記は、CVE-2020-5592の評価になります。
影響を受けるシステム


Zenphoto
  • Zenphoto 1.5.7 より前のバージョン

想定される影響

想定される影響は各脆弱性により異なりますが、次のような影響を受ける可能性があります。
・ユーザのウェブブラウザ上で任意のスクリプトが実行される - CVE-2020-5592
・攻撃者により不正に細工された .zip ファイルがアップロードされた場合、当該製品をインストールしているサーバ上で、任意の PHP コードが実行される - CVE-2020-5593
対策

[アップデートする]
開発者が提供する情報をもとに、最新版にアップデートしてください。
ベンダ情報

Zenphoto
CWEによる脆弱性タイプ一覧  CWEとは?

  1. コード・インジェクション(CWE-94) [IPA評価]
  2. クロスサイトスクリプティング(CWE-79) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2020-5592
  2. CVE-2020-5593
参考情報

  1. JVN : JVN#32252648
更新履歴

  • [2020年06月11日]
      掲載