【活用ガイド】

JVNDB-2008-001004

PostgreSQL の index() 関数における権限昇格の脆弱性

概要

PostgreSQL には、index() 関数内の VACUUM および ANALYZE オペレーションの権限をテーブル所有者の権限ではなく、スーパーユーザ権限を使用する、および index() 関数内に SET ROLE および SET SESSION AUTHORIZATION を定義することが可能な脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v2 による深刻度
基本値: 5.5 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
影響を受けるシステム


PostgreSQL.org
  • PostgreSQL 7.3.21 未満のバージョン
  • PostgreSQL 7.4.26 未満のバージョン
  • PostgreSQL 8.0.22 未満のバージョン
  • PostgreSQL 8.1.18 未満のバージョン
  • PostgreSQL 8.2.14 未満のバージョン
  • PostgreSQL 8.3.8 未満のバージョン
  • PostgreSQL 8.4.1 未満のバージョン
サン・マイクロシステムズ
  • Sun Solaris 10 (sparc) 
  • Sun Solaris 10 (x86) 
ターボリナックス
  • Turbolinux Appliance Server 1.0 (hosting) 
  • Turbolinux Appliance Server 1.0 (workgroup) 
  • Turbolinux Appliance Server 2.0  
  • Turbolinux FUJI
  • Turbolinux Multimedia
  • Turbolinux Personal
  • Turbolinux Server 10  
  • Turbolinux Server 10 (x64) 
  • Turbolinux Server 11  
  • Turbolinux Server 11 (x64) 
ミラクル・リナックス
  • Asianux Server 3.0 
  • Asianux Server 3.0 (x86-64) 
  • Asianux Server 4.0 
  • Asianux Server 4.0 (x86-64) 
  • Asianux Server 3 (x86) 
  • Asianux Server 3 (x86-64) 
  • Asianux Server 2.0 
  • Asianux Server 2.1 
レッドハット
  • Red Hat Enterprise Linux 5 (server) 
  • Red Hat Enterprise Linux 3 (as) 
  • Red Hat Enterprise Linux 4 (as) 
  • Red Hat Enterprise Linux 3 (es) 
  • Red Hat Enterprise Linux 4 (es) 
  • Red Hat Enterprise Linux 3 (ws) 
  • Red Hat Enterprise Linux 4 (ws) 
  • Red Hat Enterprise Linux Desktop 3.0 
  • Red Hat Enterprise Linux Desktop 4.0 
  • Red Hat Enterprise Linux Desktop 5.0 (client) 
  • RHEL Desktop Workstation 5 (client) 

想定される影響

第三者によって権限昇格され、更なる攻撃に利用される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

PostgreSQL.org サン・マイクロシステムズ
  • Sun Alert Notification : 103197
ターボリナックス ミラクル・リナックス
  • Asianux Technical Support Network : postgresql-8.1.11-1.1.1AX
  • MIRACLE LINUX アップデート情報 : 1228
  • MIRACLE LINUX アップデート情報 : 1229
  • MIRACLE LINUX アップデート情報 : 1811
レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2007-6600
参考情報

  1. National Vulnerability Database (NVD) : CVE-2007-6600
  2. Secunia Advisory : SA28359
  3. SecurityFocus : 27163
  4. ISS X-Force Database : 39496
  5. SecurityTracker : 1019157
  6. FrSIRT Advisories : FrSIRT/ADV-2008-0061
更新履歴

  • [2008年01月23日]
      掲載
    [2008年02月06日]
      影響を受けるシステム:ターボリナックス (TLSA-2008-6) の情報追加。
      ベンダ情報:ターボリナックス (TLSA-2008-6) 追加。
    [2008年03月18日]
      影響を受けるシステム:ミラクル・リナックス (postgresql (V3.0), postgresql (V4.0)) の情報追加。
      ベンダ情報:ミラクル・リナックス (postgresql (V3.0), postgresql (V4.0)) 追加。
    [2008年04月15日]
      影響を受けるシステム:ミラクル・リナックス (postgresql-8.1.11-1.1.1AX) の情報追加。
      ベンダ情報: ミラクル・リナックス (postgresql-8.1.11-1.1.1AX) 追加。
    [2009年10月01日]
      影響を受けるシステム:PostgreSQL.org (PostgreSQL 2009-09-09 Security Update) の情報を追加
      ベンダ情報:PostgreSQL.org (PostgreSQL 2009-09-09 Security Update) を追加
    [2009年12月18日]
      影響を受けるシステム:ミラクル・リナックス (1811) の情報を追加
      ベンダ情報:ミラクル・リナックス (1811) を追加