【活用ガイド】

JVNDB-2006-000075

libpng の png_do_strip_filler() 関数におけるヒープオーバーフローの脆弱性

概要

libpng の png_do_strip_filler() 関数には、アルファチャンネルの値を取り除く際にヒープオーバーフローが発生する脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v2 による深刻度
基本値: 5.0 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): なし
  • 可用性への影響(A): 部分的
影響を受けるシステム


ミラクル・リナックス
  • Asianux Server 4.0 
  • Asianux Server 4.0 (x86-64) 
レッドハット
  • Red Hat Enterprise Linux 4 (as) 
  • Red Hat Enterprise Linux 4 (es) 
  • Red Hat Enterprise Linux 4 (ws) 

想定される影響

libpng を使用するアプリケーションがサービス運用妨害 (DoS) 状態となる、あるいは当該アプリケーションの権限で任意のコードを実行される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

ミラクル・リナックス レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2006-0481
参考情報

  1. National Vulnerability Database (NVD) : CVE-2006-0481
  2. Secunia Advisory : SA18654
  3. SecurityFocus : 16626
更新履歴

  • [2007年04月01日]
      掲載