【活用ガイド】

JVNDB-2006-000008

PostgreSQL の postmaster におけるサービス運用妨害 (DoS) の脆弱性

概要

PostgreSQL には、Windows プラットフォームにおいて同時に大量のコネクションリクエストを処理した場合、データベースサーバプログラムである postmaster が終了してしまう脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v2 による深刻度
基本値: 5.0 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): なし
  • 可用性への影響(A): 部分的
影響を受けるシステム


PostgreSQL.org
  • PostgreSQL v8.0.5 およびそれ以前
  • PostgreSQL v8.1.1 およびそれ以前

想定される影響

postmaster の終了により、新たなデータベース接続を確立することが不可能となり、PostgreSQL がサービス運用妨害 (DoS) 状態となる可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

PostgreSQL.org
CWEによる脆弱性タイプ一覧  CWEとは?

共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2006-0105
参考情報

  1. National Vulnerability Database (NVD) : CVE-2006-0105
  2. SecurityFocus : 16201
更新履歴

  • [2007年04月01日]
      掲載