【活用ガイド】

[English]

JVNDB-2017-000247

Qt for Android における環境変数を改ざん可能な脆弱性

概要

The Qt Company が提供する Qt for Android には、環境変数を改ざん可能な脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社サイバーディフェンス研究所 永岡 悟 氏

CVSS による深刻度 (CVSS とは?)

基本値: 5.1 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 5.3 (警告) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): 低
影響を受けるシステム


The Qt Company
  • Qt for Android 5.9.3 より前のバージョン

想定される影響

遠隔の第三者によって、Qt for Android を使用して作成されたアプリケーションの環境変数を改ざんされる可能性があります。結果として、任意のコードを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。

[パッチを適用する]
Qt for Android 5.7系および 5.8系向けに修正パッチが提供されています。詳しくは開発者が提供する情報をご確認ください。
ベンダ情報

The Qt Company
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-10905
参考情報

  1. JVN : JVN#27342829
更新履歴

[2017年12月11日]
  掲載