【活用ガイド】

[English]

JVNDB-2017-000236

WordPress 用プラグイン TablePress における XML 外部実体参照 (XXE) 処理の脆弱性

概要

WordPress 用プラグイン TablePress は、WordPress サイトで使用するテーブルを生成、管理するプラグインです。TablePress には、XML 外部実体参照 (XXE) 処理の脆弱性 (CWE-611) が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: NTTコミュニケーションズ株式会社 東内裕二 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.0 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし

[参考] CVSS v3 による深刻度
基本値: 5.0 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更あり
  • 機密性への影響(C): 低
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
影響を受けるシステム


tablepress.org
  • TablePress 1.8.1 より前のバージョン

想定される影響

当該プラグインの管理ページにアクセスできる「投稿者」以上の権限を持つユーザによって、サーバ上の任意のファイルにアクセスされる可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

tablepress.org
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-10889
参考情報

  1. JVN : JVN#05398317
更新履歴

[2017年11月14日]
  掲載