【活用ガイド】

[English]

JVNDB-2015-000123

NScripter におけるバッファオーバーフローの脆弱性

概要

NScripter はゲームを作成、実行するためのスクリプトエンジンです。NScripter には、セーブデータの読み込み処理に起因するバッファオーバーフローの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 草野 一彦 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


高橋直樹
  • NScripter Ver3.00 より前のバージョン
  • NScripter Ver3.00 より前のバージョンで作成されたゲーム

想定される影響

細工されたセーブデータを読み込むことで、任意のコードを実行される可能性があります。
対策

NScripter をお使いの場合:
[アップデートし、リビルドする]
NScripter を使用したゲームの開発者は、NScripter を最新版へアップデートし、当該ゲームをリビルドしてください。

NScripter を使用したゲームをお使いの場合:
[アップデートする]
当該ゲームのユーザは、ゲーム開発者の提供する情報をもとに、当該ゲームを最新版へアップデートしてください。
ベンダ情報

高橋直樹
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-2991
参考情報

  1. JVN : JVN#08494613
  2. National Vulnerability Database (NVD) : CVE-2015-2991
  3. IPA 重要なセキュリティ情報 : 「NScripter」におけるバッファオーバーフローの脆弱性対策について(JVN#08494613)
更新履歴

[2015年09月02日]
  掲載
[2015年09月09日]
  参考情報:National Vulnerability Database (NVD) (CVE-2015-2991) を追加