【活用ガイド】

JVNDB-2012-003837

Apache HTTP Server の mod_negotiation モジュールにおけるクロスサイトスクリプティングの脆弱性

概要

Apache HTTP Server の mod_negotiation モジュールの mod_negotiation.c 内の make_variant_list 関数には、MultiViews オプションが有効になっている場合、クロスサイトスクリプティングの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 2.6 (注意) [ベンダ値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


Apache Software Foundation
  • Apache HTTP Server 2.4.3 未満の 2.4.x
アップル
  • Apple Mac OS X v10.6.8
  • Apple Mac OS X v10.7.5
  • Apple Mac OS X v10.8 から v10.8.4
  • Apple Mac OS X Server v10.6.8
  • Apple Mac OS X Server v10.7.5
オラクル
  • Oracle HTTP Server
日本電気
  • CSVIEW /FAQナビ すべてのバージョン
  • CSVIEW /Webアンケート すべてのバージョン
  • WebOTX Application Server Enterprise V8.2 から V8.5
  • WebOTX Application Server Express V8.2 から V8.5
  • WebOTX Application Server Foundation V8.2 から V8.5
  • WebOTX Application Server Standard V8.2 から V8.5
  • WebOTX Enterprise Service Bus V8.2 から V8.5
  • WebOTX Portal V8.2 から V8.4
日立
  • Cosminexus Application Server Enterprise Version 6
  • Cosminexus Application Server Standard Version 6
  • Cosminexus Application Server Version 5
  • Cosminexus Client Version 6
  • Cosminexus Developer Light Version 6
  • Cosminexus Developer Professional Version 6
  • Cosminexus Developer Standard Version 6
  • Cosminexus Developer Version 5
  • Cosminexus HTTP Server
  • Cosminexus Primary Server Base
  • Cosminexus Studio Version 5
  • Hitachi Web Server
  • Hitachi Web Server - Security Enhancement
  • uCosminexus Application Server
  • uCosminexus Application Server Express
  • uCosminexus Application Server Light
  • uCosminexus Application Server Smart
  • uCosminexus Application Server Enterprise
  • uCosminexus Application Server Smart Edition
  • uCosminexus Application Server Standard
  • uCosminexus Application Server Standard -R
  • uCosminexus Developer
  • uCosminexus Developer 01
  • uCosminexus Developer Professional
  • uCosminexus Developer Professional for Plug-in
  • uCosminexus Developer Light
  • uCosminexus Developer Standard
  • uCosminexus Primary Server Base
  • uCosminexus Service Architect
  • uCosminexus Service Platform
  • uCosminexus Service Platform - Messaging
富士通
  • Interstage Application Framework Suite
  • Interstage Application Server
  • Interstage Apworks
  • Interstage Business Application Server
  • Interstage Job Workload Server
  • Interstage Studio
  • Interstage Web Server
  • Interstage Web Server Express
  • Systemwalker Resource Coordinator

影響を受ける以下の製品の詳細なバージョンについては、ベンダの提供する情報をご確認ください。

日立製品:HS12-028
富士通製品:Interstage HTTP Server (CVE-2011-3607/ CVE-2012-3499/ CVE-2012-2687/ CVE-2013-1862)
日本電気:NV14-007
想定される影響

第三者により、variant リストの作成において適切に処理されない巧妙に細工されたファイル名を介して、任意の Web スクリプトまたは HTML を挿入される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Apache Software Foundation Canonical IBM Novell Xerox アップル オラクル レッドハット 日本電気
  • NEC製品セキュリティ情報 : NV14-007
日立
  • Hitachi Software Vulnerability Information : HS12-028
  • ソフトウェア製品セキュリティ情報 : HS12-028
富士通
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2012-2687
参考情報

  1. National Vulnerability Database (NVD) : CVE-2012-2687
更新履歴

[2012年08月24日]
  掲載
[2012年12月03日]
  影響を受けるシステム:日立 (HS12-028) の情報を追加
  ベンダ情報:日立 (HS12-028) を追加
[2012年12月26日]
  ベンダ情報:Ubuntu (USN-1627-1) を追加
[2013年01月11日]
  ベンダ情報:レッドハット (RHSA-2012:1591) を追加
  ベンダ情報:レッドハット (RHSA-2012:1592) を追加
  ベンダ情報:レッドハット (RHSA-2012:1594) を追加
[2013年01月25日]
  ベンダ情報:オラクル (Multiple vulnerabilities in Apache HTTP server) を追加
[2013年06月10日]
  ベンダ情報:Apache Software Foundation (Apache HTTP Server 2.4.3 Released) を追加
  ベンダ情報:Xerox (XRX13-003) を追加
  ベンダ情報:Novell (openSUSE-SU-2013:0243) を追加
  ベンダ情報:Novell (openSUSE-SU-2013:0245) を追加
  ベンダ情報:Novell (openSUSE-SU-2013:0248) を追加
  ベンダ情報:レッドハット (RHSA-2013:0130) を追加
[2013年07月18日]
  影響を受けるシステム:オラクル (Oracle Critical Patch Update Advisory - July 2013) の情報を追加
  ベンダ情報:オラクル (Oracle Critical Patch Update Advisory - July 2013) を追加
  ベンダ情報:オラクル (Text Form of Oracle Critical Patch Update - July 2013 Risk Matrices) を追加
  ベンダ情報:オラクル (July 2013 Critical Patch Update Released) を追加
[2013年07月25日]
  ベンダ情報:オラクル (Multiple vulnerabilities in Apache HTTP Server (Jul 16, 2013)) を追加
[2013年09月30日]
  影響を受けるシステム:アップル (HT5880) の情報を追加
  ベンダ情報:アップル (HT5880) を追加
  ベンダ情報:アップル (APPLE-SA-2013-09-12-1) を追加
[2013年11月28日]
  影響を受けるシステム:内容を更新
  ベンダ情報:IBM (SE53614) を追加
  ベンダ情報:富士通 (Interstage HTTP Server (CVE-2011-3607/ CVE-2012-3499/ CVE-2012-2687/ CVE-2013-1862)) を追加
[2014年06月03日]
  影響を受けるシステム:日本電気 (NV14-007) の情報を追加
  ベンダ情報:日本電気 (NV14-007) を追加
[2016年08月02日]
  影響を受けるシステム:ベンダ情報の更新に伴い内容を更新