[Japanese]

JVNDB-2017-000245

The installer of The Public Certification Service for Individuals "The JPKI user's software" may insecurely load Dynamic Link Libraries

Overview

The installer of The Public Certification Service for Individuals "The JPKI user's software" provided by Japan Agency for Local Authority Information Systems (J-LIS) contains an issue with the DLL search path, which may lead to insecurely loading Dynamic Link Libraries (CWE-427).

Note that this vulnerability is different from JVN#91002412 and JVN#39605485.

BlackWingCat of Pink Flying Whale reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

CVSS V3 Severity:
Base Metrics: 7.8 (High) [IPA Score]
  • Attack Vector: Local
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Unchanged
  • Confidentiality Impact: High
  • Integrity Impact: High
  • Availability Impact: High
Affected Products


Japan Agency for Local Authority Information Systems
  • The Public Certification Service for Individuals "The JPKI user's software" Ver3.1 and earlier

According to the developer, the software is affected by this vulnerability only when it is operated under Windows 7.
Impact

Arbitrary code may be executed with the privilege of the user invoking the installer.
Solution

[Use the latest installer of The Public Certification Service for Individuals "The JPKI user's software"]
Apply the patch "KB2533623" on Windows 7 and then use the latest installer of The Public Certification Service for Individuals "The JPKI user's software", according to the information provided by the developer.
Users who already have installed The Public Certification Service for Individuals "The JPKI user's software" do not need to re-install the application, because this issue affects the installer only.
Vendor Information

Japan Agency for Local Authority Information Systems
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2017-10893
References

  1. JVN : JVN#30352845
  2. JVN : JVNTA#91240916
Revision History

[2017/12/06]
  Web page was published