[Japanese]

JVNDB-2017-000075

Hoozin Viewer vulnerable to buffer overflow

Overview

Hoozin Viewer provided by ICON CORPORATION contains a buffer overflow vulnerability (CWE-121).

Touma Hatano reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 5.1 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: High
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

CVSS V3 Severity:
Base Metrics: 5.0 (Medium) [IPA Score]
  • Access Vector: Network
  • Attack Complexity: High
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Unchanged
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: Low
Affected Products


ICON CORPORATION
  • Hoozin Viewer Ver2
  • Hoozin Viewer Ver3
  • Hoozin Viewer Ver4.1.5.15 and earlier
  • Hoozin Viewer Ver5.1.2.13 and earlier
  • Hoozin Viewer Ver6.0.3.09 and earlier

Impact

If a user views a malicious page, arbitrary code may be executed.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

ICON CORPORATION
CWE (What is CWE?)

  1. Buffer Errors(CWE-119) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2017-2155
References

  1. JVN : JVN#93931029
  2. National Vulnerability Database (NVD) : CVE-2017-2155
Revision History

[2017/04/20]
  Web page was published
[2017/06/01]
  References : Content was added