[Japanese]

JVNDB-2016-000212

The installer of The Public Certification Service for Individuals "The JPKI user's software" may insecurely load Dynamic Link Libraries

Overview

The installer of The Public Certification Service for Individuals "The JPKI user's software" provided by Japan Agency for Local Authority Information Systems (J-LIS) contains an issue with the DLL search path, which may lead to insecurely loading Dynamic Link Libraries.

Yuji Tounai of NTT Communications Corporation reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

CVSS V3 Severity:
Base Metrics: 7.8 (High) [IPA Score]
  • Access Vector: Local
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Unchanged
  • Confidentiality Impact: High
  • Integrity Impact: High
  • Availability Impact: High
Affected Products

Installers of the following "The JPKI user's software" versions that were available until October 14, 2016, are affected:

Japan Agency for Local Authority Information Systems
  • The Public Certification Service for Individuals "The JPKI user's software" Ver3.0.1(for Windows 7 and later) and earlier
  • The Public Certification Service for Individuals "The JPKI user's software" Ver3.0.1(for Windows Vista) and earlier
  • The Public Certification Service for Individuals "The JPKI user's software" Ver2.6 and earlier

Impact

Arbitrary code may be executed with the privilege of the user invoking the installer.
Solution

[Use the latest installer of The Public Certification Service for Individuals "The JPKI user's software"]
Use the latest installer of The Public Certification Service for Individuals "The JPKI user's software", according to the information provided by J-LIS.

[Do not invoke the installer of The Public Certification Service for Individuals "The JPKI user's software"]
Users who have already installed The Public Certification Service for Individuals "The JPKI user's software" do not need to uninstall the application, because this vulnerability can be exploited only when installing the software. Thus it is recommended to delete old installers of the software.
Vendor Information

Japan Agency for Local Authority Information Systems
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2016-4902
References

  1. JVN : JVN#91002412
  2. National Vulnerability Database (NVD) : CVE-2016-4902
Revision History

[2016/11/01]
  Web page was published
[2016/11/16]
  Solution was modified
[2016/11/22]
  Affected Products : Content was added
  Solution was modified
[2017/12/25]
  References : Content was added