EC-CUBE plugin "Help plug-in" vulnerable to SQL injection


EC-CUBE plugin "Help plug-in" provided by Cuore contains an SQL injection vulnerability (CWE-89).

Gen Sato of TRADE WORKS Co.,Ltd. Security Dept. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 7.5 (High) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

CVSS V3 Severity:
Base Metrics: 7.3 (High) [IPA Score]
  • Access Vector: Network
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: Low
Affected Products

  • Help plug-in version 1.3.5 and earlier


Information stored in the database may be obtained or altered by a remote attacker.

[Update the plugin]
Update to the latest version according to the information provided by the developer.
Vendor Information

CWE (What is CWE?)

  1. SQL Injection(CWE-89) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2016-1154

  1. JVN : JVN#31524757
  2. National Vulnerability Database (NVD) : CVE-2016-1154
Revision History

  Web page was published
  References : Content was added