[Japanese]

JVNDB-2016-000006

Multiple Buffalo network devices vulnerable to cross-site scripting

Overview

Multiple network devices provided by BUFFALO INC. contain a cross-site scripting vulnerability.

Satoshi Ogawa of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 4.3 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: None
  • Integrity Impact: Partial
  • Availability Impact: None

CVSS V3 Severity:
Base Metrics: 6.1 (Medium) [IPA Score]
  • Access Vector: Network
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Changed
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: None
Affected Products


BUFFALO INC.
  • BHR-4GRV2 firmware Ver.1.04 and earlier
  • WEX-300 firmware Ver.1.90 and earlier
  • WHR-1166DHP firmware Ver.1.90 and earlier
  • WHR-300HP2 firmware Ver.1.90 and earlier
  • WHR-600D firmware Ver.1.90 and earlier
  • WMR-300 firmware Ver.1.90 and earlier
  • WMR-433 firmware Ver.1.01 and earlier
  • WSR-1166DHP firmware Ver.1.01

Impact

An arbitrary script may be executed on the logged in user's web browser.
Solution

[Update the firmware]
Update the firmware according to the information provided by the developer.
Vendor Information

BUFFALO INC.
CWE (What is CWE?)

  1. Cross-site Scripting(CWE-79) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2016-1135
References

  1. JVN : JVN#49225722
  2. National Vulnerability Database (NVD) : CVE-2016-1135
Revision History

[2016/01/22]
  Web page was published
[2016/03/10]
  References : Content was added