desknet's NEO vulnerable to directory traversal


desknet's NEO provided by NEOJAPAN Inc. contains a directory traversal (CWE-22) vulnerability where it fails to verify html parameter in zhtml.cgi.

Hiroyuki Yamashita of M&K Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 4.0 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: Single Instance
  • Confidentiality Impact: Partial
  • Integrity Impact: None
  • Availability Impact: None

Affected Products

  • desknet's NEO V2.0R1.0 to V2.5R1.4


An authenticated attacker may view arbitrary files on the server.

[Update the Software]
Update to the latest version according to the information provided by the developer.

[Apply the Patch]
Apply the patch according to the information provided by the developer.
Vendor Information

CWE (What is CWE?)

  1. Path Traversal(CWE-22) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2015-2990

  1. JVN : JVN#09283606
  2. National Vulnerability Database (NVD) : CVE-2015-2990
Revision History

  Web page was published
  References : Content was added