Thetis vulnerable to SQL injection


Thetis provided by Sysphonic Co., Ltd. is an open source groupware and SNS. Thetis contains a SQL injection (CWE-89) vulnerability.

Shoji Baba reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 7.5 (High) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products

Sysphonic Co., Ltd.
  • Thetis ver.2.2.0 and earlier


An attacker may obtain or alter information stored in the database.

[Apply an Update]
Apply the update according to the information provided by the provider.
Vendor Information

Sysphonic Co., Ltd.
CWE (What is CWE?)

  1. SQL Injection(CWE-89) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2015-2972

  1. JVN : JVN#19011483
  2. National Vulnerability Database (NVD) : CVE-2015-2972
Revision History

  Web page was published
  References : Content was added
  Vendor Information : Contents were added