[Japanese]

JVNDB-2015-000097

Simple Oekaki BBS vulnerability where arbitrary files may be deleted

Overview

Simple Oekaki BBS provided by LEMON-S PHP contains a flaw in parsing the oekakis parameter in index.php, which may allow a remote attacker to delete arbitrary files.

Shoji Baba reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.4 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: None
  • Confidentiality Impact: None
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


LEMON-S PHP
  • Simple Oekaki BBS versions prior to v1.21

Impact

A remote attacker may delete arbitrary files on the server.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

LEMON-S PHP
CWE (What is CWE?)

  1. Path Traversal(CWE-22) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2015-2970
References

  1. JVN : JVN#61935381
  2. National Vulnerability Database (NVD) : CVE-2015-2970
Revision History

[2015/07/10]
  Web page was published
[2015/07/14]
  References : Content was added