Maruo Editor vulnerable to buffer overflow


Maruo Editor provided by Saitoh Kikaku contains a buffer overflow vulnerability due to a flaw in processing a specially crafted .hmbook file (CWE-119).

Masato Kinugawa reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products

Saitoh Kikaku
  • Maruo Editor Ver8.51 and earlier


By processing a specially crafted .hmbook file, arbitrary code may be executed.

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

Saitoh Kikaku
CWE (What is CWE?)

  1. Buffer Errors(CWE-119) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2015-0903

  1. JVN : JVN#58784309
  2. National Vulnerability Database (NVD) : CVE-2015-0903
Revision History

  Web page was published
  References : Content was added