IrfanView vulnerable to buffer overflow


IrfanView is an application for viewing images of many different file formats.
IrfanView contains a buffer overflow vulnerability, when using the Thumbnails window with Thumbnail tooltips enabled.

Asuka Nakajima of NTT Secure Platform Laboratories reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products

Irfan Skiljan
  • IrfanView 4.36 and earlier


When processing a specially crafted file contained in a folder named using multi-byte characters, the program will crash and arbitrary code may be executed.

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

Irfan Skiljan
CWE (What is CWE?)

  1. Buffer Errors(CWE-119) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2013-6932

  1. JVN : JVN#63194482
  2. National Vulnerability Database (NVD) : CVE-2013-6932
Revision History

  Web page was published
  References : Content was added