[Japanese]

JVNDB-2012-000108

Welcart vulnerable to cross-site scripting

Overview

Welcart contains a cross-site scripting vulnerability.

Welcart provided by Collne Inc. is a WordPress plugin for creating shopping websites. Welcart contains a cross-site scripting vulnerability.

Yoshinori Matsumoto of Kobe Digital Lab., Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 5.0 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: None
  • Confidentiality Impact: None
  • Integrity Impact: Partial
  • Availability Impact: None

Affected Products


Collne Inc.
  • Welcart 1.2.1 and earlier

Impact

An arbitrary script may be executed on the management page of Welcart.
Solution

[Update the software]
Update to the latest version according to the information provided by the developer.
Vendor Information

Collne Inc.
CWE (What is CWE?)

  1. Cross-site Scripting(CWE-79) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2012-5177
References

  1. JVN : JVN#18731696
  2. National Vulnerability Database (NVD) : CVE-2012-5177
Revision History

[2012/12/14]
  Web page was published